ioBroker, Webseite nicht mehr erreichbar

  • Hallo Forum,

    leider habe ich seit zweit Tagen ein Problem mit meinem ioBroker.

    Fritzbox und Raspberry wurden neu gestartet trotzdem besteht der Fehler weiterhin.

    Per Putty ist der Raspberry über die IP Adresse erreichbar. Wenn ich im Browser die Adresse eingebe kommt immer "ERR_NAME_NOT_RESOLVED"

    Cache und Cookies wurden ebenfalls gelöscht.

    Leider komme ich nicht mehr weiter ;(

  • Das sieht stark nach einen DNS Problem aus.

    Am einfachsten wäre, Router einmal neustarten.

    Wenn es nicht von Erfolg gekrönt ist, gebe das mal bei dir am Hauptrechner ein :

    Code
    # DNS-Cache des BS löschen. 
    
    netsh winsock reset

    Sollte das immer noch keinen Erfolg haben, kann man mal einen "Reset des Winsock-Archivs" durch führen.

    Dazu muss man als Administrator cmd ausführen, und folgendes eingeben:

    Code
    netsh winsock reset

    Dann einmal neustarten und versuchen.


    Wenn es immer noch nicht geht, müsste man nach anderen Lösungen suchen.

  • Leider hat das auch nicht zum erfolg geführt.

    Die Website ist nicht erreichbar

    Die Server-IP-Adresse von 192.168.l78.56 wurde nicht gefunden

    Komisch, wenn ich ich in die Fritzbox schauen steht für iobroker genau diese IP adresse.

    Kann es vielleicht sein das die Speicherkarte zu klein (32gb) ist?!

  • ERR_NAME_NOT_RESOLVED = DNS Auflösungsfehler.

    Daher die Vermutung und dieser Lösungsweg.

    BTT:

    Setze mal die IP Adresse direkt in Debian:

    Debian: https://www.thomas-krenn.com/de/wiki/Netzwe…ation_in_Debian

    In der Fritzbox kannst Du einen Haken setzten: Immer gleiche IP vergeben.

    Wie tesso schrieb, der Port muss immer angegeben werden, außer man ändert das bewusst ab.

  • Hallo zusammen erstmal danke für die aufnahme. Ich weiß nicht ob es hier richtig ist mein Problem was ich habe? Ich habe gestern glaub einen großen scheiß gebaut mit meinem iobroker. Ich habe im iobroker atapter von ipv4 alle IP umgestellt auf wlan0 nun kann ich es nicht mehr aufrufen. Könnt ihr mir helfen? Gibt es die möglichkeit es wieder umzustellen oder muss ich alles neu machen? Mfg schlappy

  • In dem Admin Adapter?
    admin_adapter.png

    Kannst ja mal versuchen dich per Console anzumelden und folgendes einzugeben:

    Zu der Struktur: /opt/iobroker/ wechseln:

    iobroker set admin.0 --bind 0.0.0.0

    eingeben.

    und neustarten.

    Ich kann Dir nur dringend empfehlen, lege Dir ein Backup an!
    So kannst Du wenigstens den "letzten" Zustand wieder starten!

    Grüße


    *edit*

    Gerade nochmal nachgesehen und folgende Temporäre Lösung gefunden:

    Falls die Einstellungen von der Admin-Konsole verstellt sind und man nicht mehr auf Admin-Seite zugreifen kann, gibt es noch die Möglichkeit eine zweite Admin-Instanz zu installieren.

    Dafür:

    iobroker add admin --port 8089

    ausführen.

    8089 ein Port, welcher sicherlich frei ist.

    Danach kann man Admin unter http://ip:8089 erreichen.

    Nach dem also die Einstellungen wieder in Ordnung sind, sollte man die neue

    (zweite auf dem Port 8089) Instanz deinstallieren, um die Ressourcen zu sparen.

  • danke für die schnelle Antwort es hat geklappt das erste oben habe auch gleich nachgeschaut und es sind die ersten Einstellungen wieder vorhanden.

    Wie macht man das mit dem Backup ich muss sagen ich bin erst ziemlich neu was raspy angeht.

    Mfg schlappy

  • Das schönste was geht ist meiner Meinung nach, ein stabiles Windows mit VirtualBox, die Debian Umgeben wird dann quasi emuliert und Du kannst das ganze System nach belieben speichern und wiederherstellen.

    Alternativ zu Windows: Promox VE ( Hat sogar ein WebInterface zum Steuern! :) )


    Da es ein ziemlich großer Aufwand ist dies umzusetzen wenn man bereits ein System einsetzt, ist mir klar daher gibt es noch folgende Option die auch gut funktionieren:

    Der Adapter "Backitup"

    Mit diesem Adapter kannst Du ein zyklisches Backup anstoßen.
    Solltest Du mal nicht auf das WebInterface kommen, kannst Du es bequem über die Console wiederherstellen.

    Eine super Erklärung ist bei dem Adapter dabei ( auf deutsch )

    So bist Du was Deine Einstellungen ein Datenpunkte betrifft schon mal safe.
    Das Backup sollte natürlich nicht auf dem gleichen System liegen wie dein IoBroker, denn wenn die Platte oder what ever kaputt geht, ist das Backup natürlich auch weg.


    Jetzt sehe ich gerade, Dein IoBroker läuft auf einen Raspberry.
    Da geht natürlich nur der Adapter.

    Grüße

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!